Known problems and solutions

This topic lists all known problems that you may encounter while using HYCU for Google Cloud, along with their solutions.

Missing Google Cloud projects

Problem

When configuring protection sets in HYCU for Google Cloud, not all of your Google Cloud projects are listed in the Protection Sets dialog box. Switching to a billing account of another HYCU for Google Cloud subscription does not show the missing projects.

Cause

The missing projects are not linked to any Google Cloud billing account that was selected when subscribing to the service.

Solution

To solve this problem, do one of the following:

  • In Google Cloud, link the missing projects to a billing account that was selected for the HYCU for Google Cloud subscription. For instructions, see Google Cloud documentation.

  • Subscribe to HYCU for Google Cloud again and select the billing account to which your missing projects are linked.

Inability to set up manually created targets

Problem

When you try to add a manually created target, HYCU for Google Cloud reports that the target is inaccessible.

Solution

In the Google Cloud Storage service, grant your the Storage Admin (roles/storage.admin) role on the Google Cloud project of the target.

For information on the required roles for the general use of the service, see “Signing in to HYCU for Google Cloud”.

Policy assignment fails

Problem

After adding the hycu‑policy custom metadata tag to an instance in Google Compute Engine, no policy is assigned to the instance in HYCU for Google Cloud.

Cause

The symptom may indicate one of the following:

  • The instance belongs to a project that is not included in any protection set.

  • The policy that is specified for the metadata tag value does not exist.

Solution

Find the corresponding entry in the event log to identify the root cause of the problem:

  1. In the HYCU for Google Cloud web user interface, go to the Events panel and search for the following error message:

    Failed to assign a policy
  2. Click the message entry, check the Message details section for the root cause of the problem, and act accordingly.

Snapshot creation fails

Problem

When a backup task for any instance in a specific Google Cloud project is started, the snapshot creation task fails and reports an error.

Solution

In Google Compute Engine, grant your the Compute Admin (roles/compute.admin) role on the Google Cloud project.

For information on the required roles for general use of the service, see “Signing in to HYCU for Google Cloud”.

Task progress indicator remains at 0%

Problem

You experience one of the following symptoms:

  • When you start a backup task, its child task for creating disk catalog never makes any progress.

  • After you start a backup or restore task, the task gets started, but it never makes any progress.

Solution

Check if the Google Cloud project that the instance belongs to has the Cloud Pub/Sub API enabled. If it does not, enable the API for the project through the Google Cloud Console.

Restore of individual files ends with errors or fails

Problem

When a restore of individual files completes, the status of the corresponding task is Done with errors or Failed. Closer inspection reveals that some or all of your selected objects have not been restored.

Cause

The original volume no longer exists, or the credential group that is assigned to the original instance in HYCU for Google Cloud includes a user account with insufficient privileges.

Solution

Restore your files to an alternate location on the original instance, to a custom location on a different instance, or to an available target, or update the configuration of the credential group that is assigned to the original instance in HYCU for Google Cloud.

Restore of individual files fails

Problem

The restore of individual files to the original instance fails because of unsuccessful mounting of the original disk.

Cause

HYCU cannot connect to the original instance because no credential group is assigned to the instance in HYCU for Google Cloud or the credential group contains incorrect settings.

Solution

Assign a credential group to the instance or make the necessary adjustments to the credential group configuration. For instructions, see “Configuring and assigning credential groups manually”.

Inability to change the protection set or to sign in

Problem

Although you have access to Google Cloud projects that are included in multiple protection sets in HYCU for Google Cloud, only the currently selected protection set is available in the Protection Set Picker dialog box. After your web user interface session ends, you are unable to sign in again.

Solution

Contact HYCU Customer Support.

Instance backup option reconfiguration fails

Problem

After you enable the restore of individual files in the Instance Configuration dialog box for an instance running Microsoft Windows, automatic assignment of a credential group to the instance fails. HYCU for Google Cloud is therefore unable to update the configuration of the instance backup options.

Solution

Manually create a credential group and assign it to the instance, and then retry updating its configuration. For instructions on manual credential group assignment, see “Enabling access to data”.